External system import fails to import CSV file when summary is null
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
When importing or validating a CSV file in Jira, you may see the following error message:
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Error importing issue \{externalId=autoid-2070628689848586821, summary='null'}
Cause
Every issue must have a non-empty summary.
When editing a CSV file in editors like Microsoft Excel, it is common for it to create many lines at the end of the file with commas only. For example:
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Issue ID,Work ID,Issue Type,Summary,Description
1,123,Bug,"System stopped working","It's just not working. Help!"
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Solution
There are two possible ways to resolve this problem:
Ignore these errors - the valid lines will be imported successfully.
Delete the lines that are made exclusively of commas and attempt to import/validate again.
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