Event Type Name in JIRA Email Subjects Missing After Upgrade to 4.4.x or Above

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

This page includes customisations of JIRA's file system, which falls outside the scope of Atlassian Support.

Symptoms

User has upgraded to 4.4.x and found that by default the status of an issue in their email subject header has been removed.

Cause

The default behaviour in 4.4+ has been changed for this, as part of JRASERVER-12640 - GMail does not thread JIRA notification emails. Additionally, whilst not related to this KB, the sender has also changed. There is an improvement request to better handle toggling the Event Type in the sender, as in JRASERVER-25591 - Allow for enabling Event Type Name in to 'From' instead of 'Subject'.

Resolution

  • Changing the email templates will result in those files being listed in the modified-files report when JIRA starts up. This can be ignored.

  • You will need to re-apply this procedure each time you upgrade to a new version of JIRA 4.4.x.

  • At the time of writing, this procedure has been tested with JIRA 4.4. However, it is expected to work in future versions.

  • Jira 8.0 introduced batching email notifications. The steps here only applies for individual email notifications. If you follow these steps, you will need to disable batching email notifications to see the effect.

  • You can refer to Customizing email content (batched notifications) to customize the template for batched notifications

To get back to the older styled email headers, you'll need to modify the subject header templates.

  • Navigate to <jira-install>/atlassian-jira/WEB-INF/classes/templates/email/subject

  • Create a backup of this directory.

The following is the comparison between then two:

Pre-JIRA 4.4+

1 $eventTypeName: ($issue.key) $issue.summary

Post JIRA 4.4+

1 ($issue.key) $issue.summary

In the newer templates the "$eventTypeName:" was removed. If you want to restore the old subject lines, you can simply replace all the subject templates in the new installation from that of an older installation.

The steps to do this are exactly as follows:

  1. Shutdown JIRA.

  2. Backup all files in the <JIRA-install>/atlassian-jira/WEB-INF/classes/templates/email/subject directory.

  3. Overwrite all files in that directory with the ones contained in an older version of jira (eg: 4.3.0)

  4. Start JIRA.

Please make sure you perform the backup step as velocity template changes are typically not supported.

Updated on April 16, 2025

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