Estimates are not showing up on the board view while it shows values in the issue view

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

For a specific project it was noticed that no estimate values were showing up in the board view. On the other hand it was noticed that story points was visible while viewing the issue in the issue view screen.

Environment

9.4.3

Diagnosis

  • Run the following SQL query in the Jira database to verify the example issue that the estimates do not show up

    • PostgreSQL DB:

      1 2 3 4 SELECT ji.id as issue_id, cf.id as customfield_id, cfname, cfv.numbervalue FROM customfield cf, customfieldvalue cfv join jiraissue ji on cfv.issue=ji.id join project p on ji.project = p.id where cf.id = cfv.customfield and cfname = 'Story Points' and p.pkey||'-'||ji.issuenum = <issuekey>;
      • To run the query, please replace "<issuekey>" with the actual issue key. For example, TEST-123.

    • Other DB

      1 2 3 4 5 6 SELECT ji.id as issue_id, cf.id as customfield_id, cfname, cfv.numbervalue FROM customfield cf, customfieldvalue cfv join jiraissue ji on cfv.issue=ji.id join project p on ji.project = p.id where cf.id = cfv.customfield and cf.cfname = 'Story Points' and p.pkey = '<PROJECT_KEY>' and ji.issuenum = <ISSUE_NUM>;
      • To run the SQL on the issue key TEST-123, please replace "<PROJECT_KEY>" to TEST and "<ISSUE_NUM>" to 123

  • Edit the estimate value for an selected issue in board view,and verify if it just updates the value on the issue on the right side panel.

  • Check from the inspector tab of the developer tools that no value is returned by searching for ghx-statistic-badge in the board view for selected issue.

  • Collect the json data for the endpoints /rest/greenhopper/1.0/xboard/plan/backlog/data.json? and /rest/greenhopper/1.0/xboard/plan/backlog/issue.json? and verify if both show empty estimatestatistic value being returned for the issue key selected. In case value is not returned, it means the field was not indexed.

Cause

In addition to the field context and search template, the field visibility also plays a part in deciding whether a field is indexed. Refer Optimizing Custom Fields . In this case, the story points was not made visible, only in the field configuration for the particular project.

Solution

Check on the following if a custom field value does not show up in any of the screens where they are expected

  1. Search template for the custom field should be defined. It can be verified from <baseurl>/secure/admin/ViewCustomFields.jspa and selecting edit on the field

  2. The configuration scheme for the field should be properly defined in context for the project. This can be verified from <baseurl>/secure/admin/ConfigureCustomField!default.jspa?customFieldId=<customfield ID>

  3. The field should have been made visible. Check for it from the <baseurl>secure/admin/ViewFieldLayouts.jspa after selecting the field configuration used for the project

  4. Verify if the field has any non null value at all, especially if it is Jira native field. Check for it from <baseurl>secure/admin/ViewCustomFields.jspa and the issues column

Updated on March 11, 2025

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