Fix Missing Estimates on Board View in Jira Data Center
Platform Notice: Data Center Only - This article only applies to Atlassian apps on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
For a specific project, it was noticed that no Estimate values were showing up in the board view. On the other hand, story points were visible while viewing the issue in the issue view screen.
Environment
Jira Data Center 9.x
Diagnosis
Verify the values exist, but are not shown
To check if estimates are missing, you can use the following database query. If you're unfamiliar with SQL, consider consulting your database administrator.
PostgreSQL DB:
SELECT ji.id as issue_id, cf.id as customfield_id, cfname, cfv.numbervalue FROM customfield cf, customfieldvalue cfv join jiraissue ji on cfv.issue=ji.id join project p on ji.project = p.id WHERE cf.id = cfv.customfield and cfname = 'Story Points' and p.pkey||'-'||ji.issuenum = <issuekey>;To run the query, please replace "<issuekey>" with the actual issue key. For example, TEST-123.
Other DB
SELECT ji.id as issue_id, cf.id as customfield_id, cfname, cfv.numbervalue FROM customfield cf, customfieldvalue cfv join jiraissue ji on cfv.issue=ji.id join project p on ji.project = p.id WHERE cf.id = cfv.customfield and cf.cfname = 'Story Points' and p.pkey = '<PROJECT_KEY>' and ji.issuenum = <ISSUE_NUM>;To run the SQL on the issue key TEST-123, please replace "<PROJECT_KEY>" to TEST and "<ISSUE_NUM>" to 123
Edit the estimate value for a selected issue in board view and verify if it updates the value only for the issue on the right side panel.
This might indicate that the field was not indexed
Cause
In addition to the field context and search template, field visibility also plays a part in deciding whether a field is indexed. Refer to Optimizing Custom Fields for more details.
Solution
Resolve the Missing Estimates Issue
Check the following if a custom field value does not show up in any of the screens where they are expected
Check that the search template for the custom field is defined. Verify this from
<baseurl>/secure/admin/ViewCustomFields.jspaand select edit on the fieldEnsure that the configuration scheme for the field is properly defined in context for the project. Verify this from
<baseurl>/secure/admin/ConfigureCustomField!default.jspa?customFieldId=<customfield ID>Make sure the field is visible. Check
<baseurl>secure/admin/ViewFieldLayouts.jspaafter selecting the field configuration used for the projectVerify if the field has any non-null value at all, especially if it is a Jira native field. Check for it by
<baseurl>secure/admin/ViewCustomFields.jspalooking at the issues column
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