Error Occurs on detail-module Under Issue View Page in Jira Data Center
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Symptoms
The following error will appear under the detail section of the issue view page:

The following appears in the atlassian-jira.log
:
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2012-08-23 14:31:15,967 http-8080-2 ERROR XXXX 661x64771x3 XXXX XXXXXXXXX /browse/XXX-XXXX [jira.web.component.ModuleWebComponentImpl] Error rendering web panel: com.atlassian.jira.jira-view-issue-plugin:details-module (null)
Cause
This error is caused by multiple reasons:
This can be a result of errors in one of the plugins that adds additional content to the details page. An example of a plugin that adds additional content is Jira Agile. Errors in Jira Agile plugin in getting the Ranking data can result in this issue, for example JIRA Agile Operations fail due to Sanity check for setting nextId of issue. We have a bug raised for this under JRASERVER-37582 - JIRA Issue Details panel breaks when JIRA Agile ranking is broken.
Additionally it is believed to be a problem with the Jira caching or Jira is in a state which requires a restart.
Workaround
In order to clear this error, multiple steps have to be taken.
Clear caches
Clearing the Tomcat cache and restarting Jira will typically address these problems. This is done with the following:
Shutdown JIRA.
Remove the contents of the following directory:
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$JIRA_INSTALL/work
⚠️ If the directory is deleted it can cause problems depending upon the way the instance was installed. Please delete the contents only.
Start Jira.
If this does not resolve the issue, please raise a support request for Atlassian Support along with a Support Zip.
Disable the Problematic Plugin
If the problem is due to a plugin, navigate to Jira's add-on (plugin) manager and disable the problematic plugin.
Check the logs
Check atlassian-jira.log
for other related errors. One error that could lead to this is documented in Cache Delegation: null keys are not permitted.
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