Error occurred communicating with the server while running JQL Search
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
JQL Search fails with "Error occurred communicating with the server. please reload the page and try again"
Environment
Any version of Jira Software or Service management (Datacenter) with Web Application Firewall (WAF) configured.
Diagnosis
Generate HAR Logs while replicating the problem.
When reviewing the Browsers HAR logs, HTTP 403 Error is observed for certain requests from awselb.
Cause
The 403 error message indicates that access to the resource is forbidden for some reason and can typically be caused by a firewall restrictions. If in case you are using AWS WAF along with ALB, it is likely that the WAF is blocking the request. This again can be confirmed by the access logs of the load balancer.
Solution
Contact your Network Administrator and Identify the firewall or WAF rule or rule group that's blocking the request.
Make changes to the identified rule to allow your request.
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