Error "Couldn't load. Refresh" when trying to change Knowledge base settings in service project

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

When Project Admin tries to change Knowledge Base Settings from Only Confluence Users to All-logged in users or vice versa, the following error is seen: Couldn't load. Refresh

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Environment

Jira Service Management Cloud

Cause

This could happen when Anonymous access (Customers can access and send requests from the portal without logging in).is enabled under the Jira Service Management Customer Access Configuration which prevents the option from being changed to All-logged in users or Only Confluence Users.

Solution

To be able to change Knowledge Base Settings, disable Anonymous access and then update Knowledge Base Settings. Steps on how to do that are below:

  1. From the top right of your screen, select Settings (Gear Icon) > Products.

  2. Under Jira Service Management, select Customer access.

  3. Unselect Customers can access and send requests from the portal without logging in.

  4. Choose Save.

  5. Navigate to Service Project > Project Settings > Knowledge Base > Update Knowledge Base Settings from Only Confluence Users to All-logged in users or vice versa.

Once the Knowledge Base Settings are updated, enable Anonymous access again if needed.

In case the issue is still not resolved, feel free to contact Atlassian support.

Updated on April 11, 2025

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