Error arises when using Affects versions in JQL.

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

The following error arises when using Affects versions in JQL.

"The field does not exist, or you do not have permission to view it."

(Auto-migrated image: description temporarily unavailable)

Environment

Cloud

Cause

In JQL, the term "affected versions" is denoted as affectedVersion. This inconsistency is leading to the error, as JQL does not identify the "affected versions" field.

Solution

In JQL, it is recommended to use affectedVersion instead of "Affects versions" because JQL recognizes "Affects versions" as affectedVersion, and according to JQL, there is no field named "Affects versions".

(Auto-migrated image: description temporarily unavailable)
Updated on April 8, 2025

Still need help?

The Atlassian Community is here for you.