Error 500 navigating to Versions and Licenses page - ServletException

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

Navigating to versions and license page leads to an error 500.

The following appears in the "atlassian-jira.log" and UI along with the error 500.

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 Technical details Log's referral number: d06dff21-57f2-47b3-a1c9-202ea64081fd Cause Referer URL: http://<hostname>/secure/admin/WebSudoAuthenticate!default.jspa?webSudoDestination=%2Fplugins%2Fservlet%2Fapplications%2Fversions-licenses java.lang.RuntimeException: javax.servlet.ServletException: Servlet execution threw an exception java.lang.RuntimeException: javax.servlet.ServletException: Servlet execution threw an exception at com.atlassian.servicedesk.internal.util.scala.ScalaJavaInterOp$1.apply(ScalaJavaInterOp.java:27) [?:?] at com.atlassian.servicedesk.internal.utils.context.CustomerContextUtil$.outOfCustomerContext(CustomerContextUtil.scala:48) [?:?] at com.atlassian.servicedesk.internal.utils.context.CustomerContextUtil.outOfCustomerContext(CustomerContextUtil.scala) [?:?] at com.atlassian.servicedesk.internal.utils.context.CustomerContextServiceImpl.outOfCustomerContext(CustomerContextServiceImpl.java:24) [?:?] at com.atlassian.servicedesk.internal.web.CustomerContextSettingFilter.outOfCustomerContext(CustomerContextSettingFilter.java:164) [?:?] at com.atlassian.servicedesk.internal.web.CustomerContextSettingFilter.doFilterImpl(CustomerContextSettingFilter.java:120) [?:?] at com.atlassian.servicedesk.internal.web.CustomerContextSettingFilter.doFilter(CustomerContextSettingFilter.java:112) [?:?] at com.atlassian.plugin.servlet.filter.DelegatingPluginFilter.doFilter(DelegatingPluginFilter.java:64) [atlassian-plugins-servlet-4.1.0-m002.jar:?] at com.atlassian.plugin.servlet.filter.IteratingFilterChain.doFilter(IteratingFilterChain.java:37) [atlassian-plugins-servlet-4.1.0-m002.jar:?] at com.atlassian.plugin.servlet.filter.DelegatingPluginFilter$1.doFilter(DelegatingPluginFilter.java:58) [atlassian-plugins-servlet-4.1.0-m002.jar:?] at com.atlassian.analytics.client.filter.JiraAnalyticsFilter.doFilter(JiraAnalyticsFilter.java:42) [?:?] at com.atlassian.analytics.client.filter.AbstractHttpFilter.doFilter(AbstractHttpFilter.java:39) [?:?] at com.atlassian.plugin.servlet.filter.DelegatingPluginFilter.doFilter(DelegatingPluginFilter.java:64) [atlassian-plugins-servlet-4.1.0-m002.jar:?] ... Caused by: javax.servlet.ServletException: Servlet execution threw an exception ... Caused by: com.google.common.util.concurrent.ExecutionError: java.lang.NoClassDefFoundError: org/ietf/jgss/GSSException ... Caused by: java.lang.NoClassDefFoundError: org/ietf/jgss/GSSException ... Caused by: java.lang.ClassNotFoundException: org.ietf.jgss.GSSException not found by com.atlassian.upm.application-plugin [180] at org.apache.felix.framework.BundleWiringImpl.findClassOrResourceByDelegation(BundleWiringImpl.java:1532) [org.apache.felix.framework-4.2.1.jar:?] at org.apache.felix.framework.BundleWiringImpl.access$400(BundleWiringImpl.java:75) [org.apache.felix.framework-4.2.1.jar:?] at org.apache.felix.framework.BundleWiringImpl$BundleClassLoader.loadClass(BundleWiringImpl.java:1955) [org.apache.felix.framework-4.2.1.jar:?] at java.lang.ClassLoader.loadClass(ClassLoader.java:357) [?:1.8.0_51] ... 253 more

Cause

The issue has a root cause in the proxy configuration, specifically related to NTLM proxy.

If NTLM is not in use, see UPM-5223 as another bug with a similar symptom.

Workaround

Remove the proxy parameters or disable connection to Marketplace.

Resolution

This issue has been mentioned here at When using NTLM proxy, NoClassDefFoundError for class /ietf/jgss/GSSException and it has won't fix status since Atlassian does not support Proxy/SSL.

The proxy configuration needs to be changed.

Please note that configuring/supporting SSL/Proxy is not covered under Atlassian Support Offerings since customers use a variety of products and configurations. A great way to get support for unsupported queries is to ask questions on Atlassian Answers, our active user-community Q&A site.

However, Atlassian still provides some guidelines as below, but still as mentioned in the documents they are not included in support offerings.

Updated on April 8, 2025

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