Error 0x80010135: Path too long observed when extracting Jira zip file during upgrade process
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
When trying to extract the zip file, some files fail to be extracted, receiving the Windows error 0x80010135: path too long.
Environment
Jira 8.x, 9.x, 10.x
Windows environments
Diagnosis
Check if the number of characters for the Path and file name is higher than the default limit of 260.
For instance, this file failed to be extracted because it is using 273 characters:
1
E:\Atlassian\tools\atlassian-jira-software/atlassian-jira/WEB-INF/classes/com/atlassian/jira/mention/stats/UserSearchServiceStatsData$Optimised$FindTopUsersInternal$FindTopUsersWithPermissionInIssueFromGroups$FindTopUsersWithNamesInGroups$QueryDslJiraCrowdDAOSettings.class
Cause
This error is due to a default limitation of the Windows filesystem as there is a cap of 260 characters for a given file path within the Operating System due to the Win32 API.
We have a bug ticket JRASERVER-7143 - Can't unzip jira into directory with a long path name that outlines this in more detail, however as it pertains to a limit of Windows and not Jira, Atlassian cannot action on this limitation.
Solution
There are several ways to fix this, but the best method would involve enabling NTFS long paths in the Windows server to bypass the 32-bit limitation and extend the length limit to 32,767 characters. Some relevant 3rd party guide that outlines the process to update this on Windows Server 2016 and later:
Was this helpful?