Epics being assigned to Sprints when they shouldn't be

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Problem

As an administrator of a Jira Software scrum project, you may be seeing epics being added to Sprints. As the main purpose of Epics is to have a "larger user story" across multiple sprints, Epics should not be able to be added to a Sprint, or kept in one if a Jira issue is moved from a different issue type (E.g: Story, Task) to Epic.

Cause

While it is not possible to add an Epic to a sprint directly from a Scrum board, one possibility where an Epic could be added to a Sprint is that the Epic is part of an Advanced Roadmaps plan — where a Sprint could be added to an Epic issue from the plan and saved to Jira. Also, if the Sprint field is added to the issue screen that is used by the Epic issue type, it is also possible for a user to manually add a Sprint to an Epic issue manually by editing the field from the issue view.

There is a bug report raised for this limitation which can be tracked on:

Workaround

You can create an automation rule to remove any Epics from sprints whenever an Epic is assigned to a Sprint for any reason.:-

  • Pick Field Value Changed trigger. On the trigger options, select the 'Sprint' and 'Issue type' for Fields to monitor for changes

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  • Add a field condition, to make sure the rule is performed only on Epics

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  • Add another field condition, so the automation rule only runs on Epic issues that are assigned to a Sprint

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  • Finally, on the rule action, clear the 'Sprint' field

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  • Save and publish the automation rule.

Updated on April 8, 2025

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