Email fields gets "no subfield found" when using Jira Cloud for Sheets

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

When using the extension Jira Cloud for Sheets, you can export email fields like the "Reporter.emailAddress" or "Creator.emailAddress".

If it returns "no subfield found" for any user:

(Auto-migrated image: description temporarily unavailable)

And the setting in the user profile of the email address visibility is set to "Anyone"

(Auto-migrated image: description temporarily unavailable)

Cause

The global settings take precedence over individual user settings.

Solution

In the global settings of your site "https://your-site-name.atlassian.net/jira/settings/system/general-configuration" change visibility to "public":

(Auto-migrated image: description temporarily unavailable)
Updated on April 11, 2025

Still need help?

The Atlassian Community is here for you.