Duplicate Issue Type Appear In Create Issue Screen

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

  1. When user try create issue there are duplicate Issue Types as shown in the screenshot

    (Auto-migrated image: description temporarily unavailable)
  2. When Administrator check in the Global Issue Types , there is no duplicate Issue Types exist. Can be confirm in the database by running:

    1 SELECT * FROM issuetype;
  3. Duplicate Issue Types appear in the Issue Type Schemes

Cause

Duplicate entry related to Issue Type exist in the Issue Type Schemes.

Resolution

  1. Check which Issue Type Schemes that has duplicate Issue Type

  2. Run the following SQL queries:

    1 2 3 SELECT ID,CONFIGNAME FROM fieldconfigscheme where FIELDID='issuetype';   SELECT * FROM optionconfiguration where FIELDCONFIG in (SELECT ID FROM fieldconfigscheme where ID='<Issue_Type_Scheme_ID>');

    ℹ️ Look for the ID for related Issue Type Scheme name and replace ID to '<Issue_Type_Scheme_ID>'.

  3. Backup the database and delete the duplicate row related to the same OPTIONID from the optionconfiguration table.

    ℹ️ OPTIONID = Issue Type ID

  4. Restart JIRA

Updated on April 8, 2025

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