Duplicate events are fired twice (or more) when an action is performed on an issue (eg. issue created, issue assigned)

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Summary

Events are fired multiple times when an action is performed against an issue, such as create a new issue or transitioning an issue. If you have configuration which triggers based on these events, they will also be triggered multiple times resulting in duplicate actions, notifications, etc.

Environment

Jira 7, 8, 9, 10

Diagnosis

  1. When viewing the post function of the affected transition, you can see multiple post functions firing the same event

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    1. In the above example, there are 2 post functions firing events. Post function #4 is firing an 'Issue Created' event, while post function #3 is firing an event of typeID=1. 

    2. You can check the corresponding event type from the database by running the below query, replacing <Id>  with the corresponding ID from the post function. In this example, post function #3 is also firing an 'Issue Created' event

      1 2 3 4 5 6 select * from jiraeventtype where id=<Id>; jira544=# select * from jiraeventtype where id=1; id | template_id | name | description | event_type ----+-------------+---------------+------------------------------------+------------------------ 1 | | Issue Created | This is the 'issue created' event. | jira.system.event.type
  2. More often than not, your custom listeners and automations will also be triggered multiple times when this occurs.

Cause

Multiple post functions are firing the same event. This means when an actions happens, Jira will fire 2 of the same event. Any configurations listening to the events will then be triggered as many times since they are separate events.

Solution

Remove one of the post functions by

  1. Editing the affected workflow

  2. Deleting the post function

  3. Publish the workflow

Updated on March 14, 2025

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