Duplicate comment boxes are shown on View Screen in Jira when CDN is enabled

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

The content on this page relates to platforms that are not supported by Jira Applications. Consequently, Atlassian cannot guarantee that it will provide support for them. Please be aware that this material is provided for your information only, and using it is done so at your own risk.

When Configure your CDN for Jira Data Center is enabled, View Issue Screen in Jira shows two comment boxes after a user clicks on 'Add Comment' button.

The issue is seen when Visual Mode is selected.

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Environment

Any Jira Version

Diagnosis

Unfortunately, no errors are logged in the Jira log files or in a HAR file. The issue is caused by the configuration from the CDN side.

Cause

The problem is caused due to incorrect Caching content based on query string parameters set at CDN which result in missing Jira Static content cached at CDN.

Solution

Configure your AWS CloudFront to do the following:

  • Forward query strings to the origin, and cache based on all parameters in the query string.

Updated on March 10, 2025

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