Due date in team-managed software Forms are not visible to all users.
Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.
Summary
The Due date field is not visible for some users in the Jira Software Form
Environment
Jira Cloud
Cause
The affected users are added to a custom Project Role that does not have access to edit the Due date field.

Solution
Modify the permissions granted to the Project Role by following the below steps:
Navigate to the Project Settings > Access
Click on Manage Roles
Select the custom Role
Checkmark Edit any due date
Updated on April 15, 2025
Was this helpful?
Still need help?
The Atlassian Community is here for you.