Disable the invite user option from Jira App on Slack

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

When you are sharing a hyperlink to a Jira work item on Slack, the Jira App notifies you that there are users who need access to Jira Service Management with the following message:

To view this link, <username> needs access to Jira Service Management on <instance name>. Do you want to invite them?

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Cause

This is because the user in the Slack channel does not have to the agent role within Jira Service Management. In turn that user will not be able to see the contents of that work item should they click on that link.

  • Site admins will always see it because they can invite users regardless.

Solution

There is a feature request to disable this option completely, even for Admin users. With the possibility to disable this option, the Administrators will be able to control if they want their users to invite other users or not.

JRACLOUD-78922 - Possibility to disable the invite users to Jira button from Slack

This is a site-expected behavior for the admin users. Another aspect that is relevant to this scenario is the User access settings in the on the site. It is possible to prevent other agents from inviting new agents to the site. The Jira App will honor this configuration only for the users that only have the Agent role in Jira Service Management, and not site-admins. Changing the Jira Service Management product invitation permission to "Don't allow invite" will avoid this message to the agents, but site-admin will still be allowed to invite agents.

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Updated on April 8, 2025

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