Different Avatar Appears in Activity Stream for the Same User
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
Symptoms
Occasionally different avatars are shown for the same user for different updates in the Activity Stream.
Environment
Jira Data Center
Diagnosis
Edit the Activity Stream and verify if it has multiple 'Available Streams', as in Adding the Activity Stream Gadget.
Verify the URL on the avatar refers to a different application.
Cause
The Activity Stream is obtaining updates from other applications, such as Fisheye. When this happens, it uses the avatars of the user that have been set in Fisheye, even if the user is the same in both applications (same name, email, etc). Hence, the user would see different avatars for the same user in the activity stream, depending on the source of the update.
Solution
Workaround
Set the avatars to be the same in both applications.
Resolution
As this is the expected behavior of the Activity Stream, there is no resolution for this. However, we do have a feature request to handle this different, tracked in JRASERVER-30260 - Ability to choose the source for Activity Stream to retrieve avatars
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