Deleted issue still appears in filter using JQL query
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
Problem
Deleted issue still appears in JQL search queries.
For example : issue with key DEV-1350
Perform following query ;
project=DEV and issuekey>DEV-1348 and issuekey<DEV-1352
Dev-1350 will appear under the search result
However, when clicked, an error " Issue does not exist "
Diagnosis
No error appears in Jira application logs
Perform a search through Jira database
jiraissue
table, and note that the issue does not exist:1
select * from jiraissue where issuenum='1350' AND project=(select id from project where pkey='DEV');
1350 = issuenum
DEV = PKey
(substitute accordingly)
Cause
Index cache is corrupted or not properly updated
Solution
Resolution
Perform the following:
Perform a full reindex, not a background reindex
If problem still showing:
Stop Jira
Go to JIRA_HOME/caches/ and delete all the folders there.
Restart Jira
Perform a full reindex
Was this helpful?