Date Time Picker custom fields revert value updates

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

When using Date TimePicker custom fields in Jira Data Center 8.16.0, users may see that the values randomly revert back changes made to these fields of an issue. Any attempts to set a new value will result in the previous value being applied to the custom field, preventing this custom field from being updated by users.

Environment

Jira Data Center 8.16.0

BigGantt - Gantt Chart for Jira

Diagnosis

When this issue occurs, users can take a look at Jira's database for changes made to the changeitem table with the following query:

1 SELECT * FROM changeitem;

For example, when a change is made to the custom field, you may see a reference to the updated value, followed by it reverting back:

ID

groupid

FIELDTYPE

FIELD

OLDVALUE

OLDSTRING

NEWVALUE

NEWSTRING

2636157

1711697

custom

End Date

2022-08-09T23:59:59-0500

2022-08-09 11:59 PM

2022-08-30T23:59:00-0500

2022-08-30 11:59 PM

2636158

1711698

custom

End Date

2022-08-30T23:59:00-0500

2022-08-30 11:59 PM

2022-08-09T00:00:00-0500

2022-08-09 12:00 AM

In this instance, we can see that ID 2636157 shows when the new value set, followed by ID 2636158 with the reverted value.

Cause

In a particular case, the issue was discovered to be caused by a third-party app called BigGantt - Gantt Chart for Jira. This can be confirmed by temporarily disabling the plugin and attempting to set the values on the Jira issue again.

Solution

Going into BigGantt and making the task with locked dates a manual period has been known to fix the issue. Alternatively, if this doesn't work, we recommend creating a support request in the vendor's support portal.

Updated on April 2, 2025

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