Date picker field not showing value in Advanced Roadmaps plan in Jira Cloud

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

Issues that have dates set in a custom date picker field don't reflect those values in the plan view. The date appears correctly on the issue view.

Cause

Date picker fields must have their Search Template set to "Date Range picker" in order to work correctly.

It's possible for this setting to be "None." When that's the case, the field works on issue view, but not in Advanced Roadmaps plans.

Set the Search Template for your custom date picker field

As a Jira Administrator:

  1. Select ⚙️Settings > Issues

  2. Select Custom fields

  3. Search or scroll to find your field, and select ... (More options) > Edit details

  4. Use the Search Template dropdown to select Date Range picker instead of "None"

  5. Select Update to save changes

example date field with the search template selector expanded. the options are none and date range picker.
Updated on April 8, 2025

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