Dashboard not Loading due to Bamboo Portlet

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

After adding the Bamboo portlet, the dashboard does not load for the user. The following error appears in the atlassian-jira.log:

1 2 3 4 2009-08-27 13:55:12,245 http-8090-Processor19 ERROR [ext.bamboo.portlets.StatusPortlet] java.net.ConnectException: Connection timed out java.net.ConnectException: Connection timed out at java.net.PlainSocketImpl.socketConnect(Native Method) at java.net.PlainSocketImpl.doConnect(PlainSocketImpl.java:333)

Cause

The Bamboo server is not reachable.

Workaround

  1. Disable two Bamboo modules plugin under Administration > Plugins > JIRA Bamboo Plugin > ( Bamboo Status and Build Summary Graphs )

  2. Re-enable the portlets once connectivity to the Bamboo server is restored.

Resolution

Upgrade to JIRA 4, to replace the portlet with the gadget.

Updated on April 8, 2025

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