Dashboard gadgets fail to load in Jira server
Platform Notice: Data Center Only - This article only applies to Atlassian apps on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
Symptoms
A dashboard is not able to load a gadget.
The following appears in the atlassian-jira.log:
2013-08-21 12:42:37,398 http-bio-80-exec-12903 WARN xxxxxx 762x311586x3 66n18c 192.168.213.19 /secure/Dashboard.jspa [gadgets.renderer.internal.GadgetSpecFactoryImpl] Error occurred while retrieving gadget spec for rest/gadgets/1.0/g/com.atlassian.jira.gadgets:text-gadget/gadgets/text-gadget.xml
[gadgets.embedded.internal.GadgetUrlBuilder] GadgetUrlBuilder: could not parse spec at rest/gadgets/1.0/g/com.atlassian.jira.gadgets:text-gadget/gadgets/text-gadget.xmlDiagnosis
The exception does not indicate an application URL which means that the issue is coming from the Jira URL itself. If a URL is present, you can refer to another KB Confluence gadget in Jira server throws gadget spec error. Additionally, verify that all related plugins are compatible with the current Jira version using the Atlassian Marketplace. Look for compatibility warnings or version mismatches.
Cause
Possible causes:
The Atlassian Jira - Plugins - Gadgets Plugin is disabled.
The server or proxy configuration header size limits are too small, preventing the gadget from loading. This can result in errors like 'HTTP Status 400 - Bad Request'.
Gadget may not load after upgrading Jira, particularly if plugins (e.g., Jira Calendar Plugin, Charting for Jira) are outdated or incompatible with the current Jira version.
Solution
Resolution
Go to Jira Administration > Add-ons > Manage Add-ons > Change search option to System > Search for Atlassian Jira - Plugins - Gadgets Plugin
Click on the plugin. A list of modules will show up.
Enable the Text (text-gadget) module in the Gadgets Plugin - OR - related plugin which is missing.
If the issue persists, verify the server and proxy configurations to ensure the header size limits meet the required threshold. For detailed steps, refer to this Jira support article on header size limits. Adjust the settings in both the server and proxy to resolve configuration issues.
Follow the steps below if the add-on version is not compatible:
Go to Jira Administration > Add-ons > Manage Add-ons > check and update all related plugins to versions compatible with your Jira instance. For example, update the Jira Calendar Plugin or the Charting for Jira plugin to their latest compatible versions.
After updating plugins, ensure all nodes in the Jira instance are restarted to apply changes.
If the issue persists, check for and enable the 'Text (text-gadget)' module in the 'Atlassian Jira - Plugins - Gadgets Plugin' or any related plugin which is missing.
Steps to resolve SSL trust and JVM configuration issues:
Check Jira's SSL certificate to ensure it is trusted by its JVM. To do this, identify the correct base URL being used and use tools like `keytool` to check the trust status. Import the SSL certificate into the JVM's trust store if it's missing.
Verify that the correct JRE is configured for Jira by reviewing and updating the `setenv.sh` file if necessary. Ensure all nodes, especially in clustered setups, have the same configurations and updated cacerts file. After making these changes, restart Jira to apply the updated configurations.
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