Customer Satisfaction rating page is empty/blank when opening it from the Request Resolved notification
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
Symptoms
When clicking on the customer satisfaction link from the customer notification to provide the 5 stars rating to the support ticket, a blank/empty page is loaded:

Expected results
The page should load and should show the 5 star rating along with a test box to add a comment:

Diagnosis
When checking the console log from the browser development tool (for example from Chrome), the following error is thrown:
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batch.js?locale=en-US:269 Uncaught TypeError: Cannot read property 'key' of undefined at f (batch.js?locale=en-US:269) at p (batch.js?locale=en-US:269) at HTMLDocument.<anonymous> (batch.js?locale=en-US:269) at c (batch.js?locale=en-US:41) at Object.fireWith [as resolveWith] (batch.js?locale=en-US:41) at Function.ready (batch.js?locale=en-US:41) at HTMLDocument.H (batch.js?locale=en-US:41)
The issue goes away after entering plugin safemode
Cause
Some 3rd party add-ons can potentially break the display of the Customer Satisfaction page. So far, only the add-on Table Grid Next Generation has been identified as a potential one causing the problem, but other add-ons might also cause this issue.
Solution
Workaround
Identify which 3rd party add-on is causing the issue. To identify it:
First, enable plugin safe mode and confirm that the issue goes away
If the issue goes away, re-enable each 3rd party add-on 1 by 1 until the issue appears again. If the issue appears again, then you'll know that the add-on re-enabled last is causing the issue
Once you identified the problematic add-on, reach out to the add-on support team, since 3rd party add-ons fall outside of Atlassian Support Offerings scope.
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