Customer Portal reCAPTCHA Error

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

The portal user is getting the following error when submitting a new issue from the portal.

Error: Couldn't send Request. We couldn't verify that you are not a robot. Try sending the request again.

Cause

This issue is usually associated with the customer's location. In some locations, like China, Google Recaptcha is blocked due to the Great Firewall, and we use this tool to avoid bots creating new cases and overflowing the instance. Similar to any other tool, the ReCaptcha must be filled to allow ticket creation.

Solution

There are two solutions for this scenario:

  1. Use a VPN in another location that allows Google ReCaptcha;

  2. Open a ticket with the Atlassian Support team to deactivate the Google ReCaptcha in your instance (it will deactivate the ReCaptcha for all the users).

We have feature requests to improve this process and allow the instance admins to activate and deactivate the ReCaptcha from the portal and for a specific user.

Updated on April 8, 2025

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