Customer notification are not being delivered after upgrade to Jira Service Management 10

Platform Notice: Data Center Only - This article only applies to Atlassian apps on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

After upgrading Jira Service Management Data Center to version 10.x, customer stop receiving the email notifications including request creation, comments, and resolution.

Environment

  • JSM Data Center version 10.0.0 and later

  • Java 17

Diagnosis

  • No errors are reported in the atlassian-jira-outgoing-mail.log file, even with the debug enabled.

  • The AO_4E8AE6_NOTIF_BATCH_QUEUE table contains no entries that confirms the notifications are not being generated.

Cause

Jira Service Management 10.x uses Java 17 that enforces stricter internal reflection security. If the required JVM arguments --add-opens are missing from the startup configuration, background event handlers like onCommitEvent cannot access Java internal classes. This prevents the generation of specific customer notifications.

Following error is typically found in the atlassian-jira.log:

Jira notification Error

ERROR [c.a.s.internal.util.SafeRunner] Unable to run event handler onCommitEvent com.google.gson.JsonIOException: Failed making field "java.time.Instant#seconds" accessible ... Caused by: java.lang.reflect.InaccessibleObjectException: Unable to make field private final long java.time.Instant.seconds accessible: module java.base does not "opens java.time" to unnamed module

Solution

To resolve this issue, add the required Java 17 --add-opens arguments to the Jira JVM startup configuration. These arguments are listed in a reference file within the installation directory.

Step 1: Identify the required arguments

  1. Navigate to the <Jira-Install-Directory>/bin folder on your Jira server.

  2. Open the file java-opens.txt.

  3. Copy all the --add-opens parameters listed in this file.

Step 2: Apply arguments to the configuration

Depending on how you start Jira, apply the copied arguments to the appropriate configuration file.

For Linux (Standard installations):

  1. Edit the <Jira-Install-Directory>/bin/setenv.sh file.

  2. Locate the JVM_SUPPORT_RECOMMENDED_ARGS variable.

  3. Paste the arguments from java-opens.txt into this variable.

  4. Save the file and restart Jira.

For Linux (Systemd service):

  1. If you run Jira as a systemd service, the setenv.sh file might be bypassed.

  2. Edit your service configuration file, typically located at /etc/systemd/system/jira.service.

  3. Locate the line starting with Environment='CATALINA_OPTS=...'.

  4. Append the --add-opens arguments to this line.

  5. Run systemctl daemon-reload to refresh the service configuration.

  6. Restart the Jira service.

For Windows(starting from .bat or as service) refer to the Setting properties and options on startup | Administering Jira applications Data Center 11.3 | Atlassian Documentation to update the JVM arguments

Step 3: Verify the configuration

  1. Log in to Jira as a System Administrator.

  2. Go to Administration > System > System info.

  3. Locate the JVM Input Arguments section.

  4. Confirm all the --add-opens parameters you added are visible in this list.

  5. Create a new request in a Service Management project portal to verify notifications are working.

Updated on April 14, 2026

Still need help?

The Atlassian Community is here for you.