Resolve Missing Custom Field Values in Jira Cloud Automations and JQL
Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.
Summary
You observe that the values of a Select List custom field can't be found in any of the following scenarios:
The configured options are not listed when adding the field to a Jira Automation rule
When trying to search for the field as part of a JQL (Jira Query Language), an error message states that it can't be searched.
But when interacting with the field within the Work Item View, users can still select values from the field.
Diagnosis
Trying to search for the custom field using JQL returns the error
Field 'cf[xxxxx]' is not searchable, it is only sortable.
For automation rules, the field can be added to a rule element, such as a field value condition; however, trying to select an option for the value returns no data.
Cause
The field does not have a Search Template associated with it.
Solution
Setting a Search Template for the field will allow the field to be searched through JQL and the options to be listed via automation rules.
Navigate to Settings (⚙)
Select Work Items
Choose Custom fields
Search for the affected field using the field's name
Click on the ⋯ button to the right of the field, and select Edit
In the Search Template drop-down, select a template other than None
Related articles
The following article covers a scenario where, due to Work Item scope configuration on a custom field, data is not returned when searched via the issue search:
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