Custom field does not map after performing CSV import

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

In this article we are going to discuss a scenario in one of the custom field(named severity) in target Jira instance is not able to map value from custom field(also name severity) of source Jira instance. 

Environment

Jira 8.x and later

Diagnosis

  • Let's say there are two custom field of type "Select List(Single Choice)" with same name "Severity". One of them has customFieldId=10200 another one customFieldId=10201. User requirement is to map Severity field (having customFieldId=10201) with source Severity customField.

  • SQL debug logs helped to analyse this. After import it has been observed from Jira SQL log file that values are set against first customFieldId always

1 2022-07-25 00:22:59,552-0400 JiraTaskExecutionThread-5 user@samplecompany.com 22x114540x1 1e92f5z /secure/admin/ImporterLogsPage!import.jspa 0ms "INSERT INTO public.customfieldvalue (ID, ISSUE, CUSTOMFIELD, UPDATED, PARENTKEY, STRINGVALUE, NUMBERVALUE, TEXTVALUE, DATEVALUE, VALUETYPE) VALUES ('14536650', '1580060', '10200', '1658722979552', 'null', '33306', 'null', 'null', 'null', 'null')"
  • We can check details of custom-field with id 10200, which we got from SQL logging. We found that it is not that custom-field where we are trying to import values.

1 2 3 SELECT * FROM CUSTOMFIELD c WHERE id = '10200'; 10200 | com.atlassian.jira.plugin.system.customfieldtypes:select | | Severity | Severity: created by during import process | | | | |

Cause

  • There are already known issues with duplicate custom fields mentioned in feature request JRASERVER-61376. This feature is yet to be implemented. Thus we should avoid using duplicate custom fields.

Solution

  • User should avoid using duplicate custom field due to additional known issues as mentioned in JRASERVER-61376.

  • As a workaround user can first rename the custom field which user actually want to be set in ticket and then import csv again. Map source custom field with renamed custom field of target Jira instance for example severity custom field is renamed NewSeverity. This will ensure values from source are set for renamed custom field. 

  • Finally user can rename this custom field back to original for example rename NewSeverity to severity. This would help resolve the problem.

Updated on February 25, 2025

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