CSV Import: Unable to create issue due to invalid data in the 'Team' field

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

When using CSV import to create new issues, it triggers an error when there's an invalid data in the 'Team' field.

The error can be one of the following:

  • Error - Issue can't be created due to the error/s [ Cannot assign a non-existing team ]

  • Cannot add value to CustomField Team in Issue with summary '<Issue Summary>': Error fetching the team with the given Team Id

Cause

In the CSV file, the value of the 'Team' field should be the team ID instead of the actual team name.

Solution

Edit the CSV file and replace the value of the team name with the team ID.

Different ways to obtain team ID

  • Option 1: Select Teams > Team name

    The team ID is appended at the end of the URL, for example, https:<sitename>.atlassian.net/jira/people/team/<TeamID>

  • Option 2: Search for the team ID via JQL

    Note: this will require advanced JQL search

    (Auto-migrated image: description temporarily unavailable)

    The team name will automatically be converted to team ID when searching:

    (Auto-migrated image: description temporarily unavailable)
Updated on April 8, 2025

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