CSV import fails to create or update work items with specified status in Jira Cloud

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

CSV import fails to set work items to the specified status, even when the status exists in the destination project and no default status is defined.

Diagnosis

Validating the Status

  1. Validate that the status name in the CSV doesn't have a mismatch in name, which means there should not be any spelling mistakes, case sensitivity should be adhered to, and no space padding at the initial or end of the record name.

  2. Field "Status" must be mapped to the one under Work item Fields.

  3. Pay close attention to the map field by checking the “Map Field Value” box on the field mapping page during import.

  4. Before beginning the import page, validate whether the status field is pointing to the Custom field (Status).

Cause

Duplicate status fields in work item mapping

Due to multiple fields with the same name called “Status,” one is a custom field, and the other is a system/Workitem field. The importer is pointing to the Custom field “Status” despite choosing the Workitem field.

Solution

As the site has one custom field called "Status", the Importer tool is identifying the status as "Customfield" even when we select the work item field "Status". To resolve the problem, follow the steps below:

  1. On the field Mapping page of Import, first select the custom field "Status".

  2. Then again, search the "Status" field and select “Status” from the Work Item Fields

  3. This should resolve the problem.

Updated on June 5, 2025

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