Creating issues inline under a Sprint in a board places the newly created issue under the backlog rather than the sprint
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
Problem
When creating an issue directly from a Sprint in the board backlog page, the issue gets directed and is shown in the backlog section rather than under the Sprint.
Diagnosis
Verify that the issue is not specific to user, project, board, sprint
Go to the Field Configuration page and edit this. Here search for the Sprint Field. If you find 2 fields called Sprint, one locked and one unlocked, then you face the issue addressed here.
Cause
Users created a custom field and named it Sprint. Due to this, the system (Locked) field is hidden from Project settings -> Fields
for every project.
Solution
Resolution
Go to Custom Fields page in the instance and look for the Sprint Field
Edit the non-Locked "Sprint" field and rename it to "Sprint Duplicate"
Go to Board and try to create an issue in the sprint. The issue should now be created under the Sprint rather than under the backlog.
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