Create Issues with the Same Summary Using Jelly Script Fails due to 'Duplicate Issue' Error

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

Creating multiple issues with the same summary causes the following error:

1 2 3 4 5 6 *Error*: <JiraJelly xmlns:jira="jelly:com.atlassian.jira.jelly.JiraTagLib"><Error action="CreateIssueDetails"> <TagContents>(CreateIssue(issueKeyVar=issuekey1)(summary=Issue summary 111)(issuetype=10) (reporter=terry.ooi)(project-key=TST)(assignee=terry.ooi)(priority=3)(pid=10060)) </TagContents><ExecutedAs>user=terry.ooi</ExecutedAs> <ErrorMessage>Duplicate Issue : Another issue for this project with the same values for "summary"</ErrorMessage></Error>

Cause

The Jelly tag jira:CreateIssue will throw an error if not configured to ignore issues with duplicate summaries.

Resolution

Add the attribute duplicateSummary=ignore to the jira:CreateIssue tag.

Updated on April 8, 2025

Still need help?

The Atlassian Community is here for you.