Create issue post function not working when issue is created through email

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

Create issue post function is not working when issues are created through email, however it is working as intended when issue is created by logging into JIRA.

Diagnosis & Symptoms

  • The post function comes from third party plugin

  • The post function can be updating a custom field or something similar

  • Further investigation shows that if the relevant permission are granted to Anyone, the post function can be executed successfully

  • For example, if the post function is unable to update Epic Link, grant the Edit Issue and Link Issue permission

Cause

It is possible that the post function is not executed with a valid user with the relevant permission when the issue is created through email.

Workaround

Consult the plugin vendor for more information.

Updated on April 8, 2025

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