Count of active users is greater than the total number of users
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Symptoms
Jira shows a count of active users that is greater than the total number of users in the instance.
There are currently 8 total user(s) set up in Jira, of which 17 are active and count towards your license limit.
Cause
The root cause of this issue is still under investigation. Early investigation of the bug report below suggests that users can still be present on the cwd_membership or membership base
tables even after they have been deleted from Jira.
JRASERVER-19805 - Active user count can be higher than the total number of users
As Jira counts the number of active users based on all users granted the USE
permission, an entry on the cwd_membership
or membership base of a
user that does not exist anymore on the cwd_user
or userbase
but has been granted the USE
permission in the past will be considered an active user.
Diagnosis
In order to check if your instance is affected by this bug, run the following query.
SELECT FROM cwd_membership WHERE child_id NOT IN (SELECT id FROM cwd_user);
Workaround
Always back up your data before making any database modifications. If possible, test any alter, insert, update, or delete SQL commands on a staging server first.
For now, the way to workaround this problem is to delete entries of non-existing users from the membership tables.
DELETE FROM cwd_membership WHERE child_id NOT IN (SELECT id FROM cwd_user);
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