Communication Breakdown error on issue comment due to Nginx proxy

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

When commenting on an issue, the browser is loading non-stop and end up with Communication Breakdown error. However, the comment is displayed correctly on the issue.

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Cause

This is a known problem with Nginx version 0.7.65. Please refer to JRA-28912 for detailed information.

Workaround

As a temporary measure, please disable the keepalive in Nginx side.

Resolution

  • Upgrade Nginx to version 0.8.54 and above

  • Make sure the GZIP compression is enabled

Updated on April 15, 2025

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