Comment visibility dropdown get displayed on comment field of SD issue

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

When SD agent tries to add a comment to a SD ticket, the comment visibility dropdown get displayed along with "Share with customer" and "Comment internally" buttons on the comment field.

See screenshot below:

(Auto-migrated image: description temporarily unavailable)

Diagnostic Steps

  • No additional third party plugins are installed/enabled.

  • A user tier based license is used to be applied to Jira Service Management plugin.

  • Following query returns "TBP"

    1 select propertyvalue from propertystring where id in (select id from propertyentry where property_key like '%com.atlassian.servicedesk.renaissance.migration.type%');

Cause

Before we introduced agent based license, Jira Service Management is using the same mechanism as Jira to control the comment visibility. In order to keep the backward compatibility this dropdown will still get displayed in the newer version of JSD which allows user to modify visibility of comments created in the old version of Service Management.

Workaround

This is an expected behaviour.

Updated on April 8, 2025

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