Comment Handler Is Unable to Identify Issue

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

The following error appears in the logs:

1 Could not find a corresponding issue to comment and Create Issue Handler is not selected

Cause

A comment mail handler has been configured. When processing the emails, JIRA examines the email subject and the in-reply-to message for an existing issue reference to determine on which issue to comment. If the email does not have a valid issue id in the subject, and the email is not an in-reply-to a JIRA notification, the mail handler is not able to identify which issue to comment, and the email is discarded.

Resolution

The recommendation is to configure the forward emails property so those messages that cannot be handled by JIRA are forwarded to another email account.

Updated on April 8, 2025

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