Closing an Issue Results in 'Column 'ID' cannot be null' Error
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Symptoms
When resolving or closing an open issue, the following error often (but not always) occurs:
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Could not create new current step for #10063: root cause: while inserting: [GenericEntity:OSCurrentStep][id,null][startDate,2009-08-27 12:35:04.443][status,Resolved][owner,][finishDate,null][actionId,0][stepId,4][dueDate,null][entryId,10063] (SQL Exception while executing the following:INSERT INTO OS_CURRENTSTEP (ID, ENTRY_ID, STEP_ID, ACTION_ID, OWNER, START_DATE, DUE_DATE, FINISH_DATE, STATUS, CALLER) VALUES (?, ?, ?, ?, ?, ?, ?, ?, ?, ?) (Column 'ID' cannot be null))
Cause
A foreign key is mismatched in the database.
Resolution
Run the integrity checker.
If this is occurring frequently, you should double-check the logs and see if there are any intermittent failures with your database connection, and to validate the connections first. For details, see:
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