Cloning issues in Jira Data Center fails with a NullPointerException error
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
When attempting to clone an issue in Jira Data Center, the error admin.errors.exception java.lang.NullPointerException is displayed and no cloned issue is created.
Environment
Jira Data Center 7.x - 10.x
Diagnosis
The following error message appears in the Jira application log:
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2024-07-23 00:00:00,000+0000 https-jsse-nio-8443-exec-1 ERROR username 123x45678x9 abc123 1.2.3.4 /secure/CloneIssueDetails.jspa [c.a.j.w.action.issue.CloneIssueDetails] java.lang.NullPointerException
java.lang.NullPointerException
at com.atlassian.jira.web.action.issue.CloneIssueDetails.getRedirectToIssue(CloneIssueDetails.java:274)
at com.atlassian.jira.web.action.issue.CloneIssueDetails.doExecute(CloneIssueDetails.java:223)
at webwork.action.ActionSupport.execute(ActionSupport.java:165)
Cause
When an issue is cloned in Jira, the clone operation is performed as a separate process which runs in the background and returns a result (including any errors) when it finishes.
This error occurs when the cloning process incorrectly returns a blank result which Jira can't interpret. The most common reason for this is a problem with an app that was installed or updated in Jira.
Solution
The fact that the cloning takes place in a separate process makes it impossible to determine which app caused the problem from the error message alone, so the first step should be to determine whether any apps were recently installed or updated when the problem started to occur. App installs and upgrades will appear in the Jira application logs as upm.auditLog.install.plugin.success messages, so checking those logs may be helpful.
Once a suspect app has been identified, the next step should be to temporarily disable it by following the steps in Disabling and enabling apps, then check whether the problem persists. If cloning works after disabling the app, contact the app vendor for assistance.
If the above approach doesn't point to any clear suspects, then the next step would be to temporarily enable Safe Mode as described in Disabling and enabling apps. If cloning works with Safe Mode enabled we know that one of the installed apps is responsible, so we can turn off Safe Mode and then disable the installed apps one by one until the culprit is found, then contact the that app's vendor for assistance.
If the problem persists even with Safe Mode enabled, please contact Atlassian Support.
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