Clicking on a Component Displays an Empty Screen

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

When trying to view issues by component on the Project Page the Issues page appears blank on the Screen. Clicking on Roadmap, gives you an error on the screen.

1 2 3 4 Caused by: java.lang.NullPointerException at com.atlassian.jira.bc.project.component.CachingProjectComponentStore.findByComponentNameCaseInSensitive(CachingProjectComponentStore.java:160) at com.atlassian.jira.bc.project.component.DefaultProjectComponentManager.findByComponentNameCaseInSensitive(DefaultProjectComponentManager.java:234) at com.atlassian.jira.jql.resolver.ComponentResolver.getIdsFromName(ComponentResolver.java:30)

Cause

There is a component without a name.

Resolution

Browse to Administer >> Project >> Components and delete the null component.

Alternatively, if it is not possible to locate the null component via the UI, review the table 'component' in JIRA's database for any rows with a missing/null value in the cname field.

ℹ️ Note that, removing the component through the database, requires a restart of JIRA and/or possibly clearing out the contents of <jira-install>/work directory.

Updated on April 8, 2025

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