Changing Issue Type via Automation messed up the workflow transitions

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

The issue types involved are associated to different workflow.

When we update Jira issue type via automation rule, the issue type seems to be updated but the workflow transitions are missing/incorrect and the issue still associated with the previous workflow status from the issue view.

(Auto-migrated image: description temporarily unavailable)

Environment

Jira 8.x with Automation for Jira app

Diagnosis

  • This issue is specific to the issue type change performed via automation/script/database update.

  • Both issue types involved (original and new issue types) are associated with different workflows.

  • There's no error in the logs but the trait to this, is that the issue status does not match the current associated workflow and the workflow transitions are missing/incorrect despite user has permission to transition the issue.

  • Integrity checker doesn't highlight the workflow inconsistency.

Cause

With Automation for Jira, when we create a rule to update the issue type, the following warning reminds us of the impact of the update:

(Auto-migrated image: description temporarily unavailable)

When we attempt to manually update the Jira issue according to the same use case (Incident → Change) via Edit issue, Jira reminds us that there are no other issue type sharing the same workflow. If there are other Issue types sharing the same workflow, it will be listed as options to change.

(Auto-migrated image: description temporarily unavailable)

Issue type update involving two different workflows require us to explicitly specify how the current workflow status is map to the next workflow to ensure smooth transition.

Solution

  • How to change the issue type between two different workflows correctly?

    The correct approach to update the Jira issue type is to move the issue across to different issue type via the Move option:

    (Auto-migrated image: description temporarily unavailable)

    Follow the step-by-step wizard to move the issue across to a different issue type associated to different workflow.

  • How to fix up the issue in inconsistent state?

⚠️ Backup Jira before proceeding. Rollback to the backup should there be any issue with the fix.

  1. Identify the relevant workflows.

    For example: If we used automation rule to update issues with Incident issue type to Change issue type. Then, we are going to update the workflow scheme focusing on the workflow associated to the Change issue type.

  2. Navigate to the Jira Administration » Issues » Workflow schemes and edit the workflow scheme associated to the project where the problematic issues are from.

    ℹ️ Be aware of the impact of the workflow scheme update by checking how many project is associated to this workflow scheme. If required, we can copy this workflow scheme and make this copy specific to this project to minimise the impact of the updates.

    (Auto-migrated image: description temporarily unavailable)
  3. Assign the new issue type with the original issue type's workflow.

    For example: The issue was originally associated to Incident issue type and now it's changed to Change issue type. So I assign Change issue type to use the same workflow as Incident issue type. As we published the change, the step-by-step wizard will guide us in mapping the workflow status from one to another accordingly.

    (Auto-migrated image: description temporarily unavailable)
  4. Once done, we can then Add Workflow » Add Existing or Assign the new issue type back to its intended workflow. As we published the change again, the step-by-step wizard will guide us in mapping the workflow status from one to another accordingly.

    (Auto-migrated image: description temporarily unavailable)
  5. Now the problematic issue should be associated to the correct workflow status and with the correct workflow transitions.

    (Auto-migrated image: description temporarily unavailable)
Updated on April 8, 2025

Still need help?

The Atlassian Community is here for you.