Certificate for IP-Address doesn't match common name of the certificate subject: hostname

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

The following appears in the atlassian-jira.log

1 2 2016-12-11 16:32:15,154 ajp-nio-8009-exec-8 ERROR anonymous 992x8239x1 - xx.x.x.x.x / [c.a.g.r.internal.http.HttpClientFetcher] Unable to retrieve response javax.net.ssl.SSLException: Certificate for <123.123.123.123> doesn't match common name of the certificate subject: jira.com

Diagnosis

Diagnostic Steps

  • Ensure the imported certificate has the correct common name (CN) for JIRA hostname.

  • Check if any user are accessing JIRA with IP Address.

Root Cause

The errors thrown when other user connect JIRA using alternative ways like IP and FQDN over LAN.

Updated on April 8, 2025

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