CAPTCHA Does not Appear Despite Several Login Attempts
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Symptoms
Although CAPTCHA is enabled in the JIRA Administration Panel (CAPTCHA on signupON), a CAPTCHA does not appear regardless of invalid login attempts. Nothing appears in logs.
Cause
This may be caused by customizations of Seraph authenticators ($JIRA_INSTALL/atlassian-jira/WEB-INF/classes/seraph-config.xml). If you want to get CAPTCHA working, please refer the external authenticator set on this file.
Resolution
Backup and replace your $JIRA_INSTALL/atlassian-jira/WEB-INF/classes/seraph-config.xml with the original version you're using. If anything else has been changed when implementing the external authenticator, roll that back also.
Was this helpful?