Can't search on custom field in the Jira issue Search page

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

A Jira user is unable to select a few custom field checkboxes while searching for issues. It's showing a red exclamation mark with the message "<Customfield Name> is not applicable for the current project and/or issue type". The purpose of this knowledge article is to list the most common root causes for this issue, how to identify and fix them.

Environment

Jira Software v8.x and above.

Diagnosis

  • In the Issues Search Navigator select a custom field, from the More dropdown.

  • An error appears: "<Customfield Name> is not applicable for the current project and/or issue type":

    (Auto-migrated image: description temporarily unavailable)

Cause:1

The Search Template value could have been changed in the respective Custom Fields (which can be checked by navigating to > Issues > Custom fields, searching for the field, and clicking on ... > Edit Details.

In the example below, the Search Template is set to None:

(Auto-migrated image: description temporarily unavailable)

Cause:2

A field is "not applicable" when the context for the custom field does not place it on that project and issue type.

Cause:3

The custom field might not have been associated with the project screens.

Cause:4

This could occur when the custom field is hidden from the Project's Field Configuration.

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Solution: 1

1. Go to > Issues > Custom fields.

2. Find the respective field and Edit.

3. Set the Search Template value to Free Text Searcher if it is a Text Field type custom field.

Solution: 2

1. Go to > Issues > Custom fields.

2. Select Configure under actions => Edit Configuration. You can find a context that specifies projects and/or issue types where the field belongs.

3. Please change the context with respect to the filter search you're looking for.

Solution: 3

1. Go to > Issues

2. Select Field configurations and configure.

3. Search for the custom field and click on screens to verify if the custom field is associated with the project screens.

Solution: 4

1. Go to > Issues

2. Select Field configurations and configure.

3. Search for the custom field and click onShow to verify.

Updated on April 24, 2025

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