Cannot Login to JIRA after Upgrade due to Null Pointer Exception

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Symptoms

At the 96% mark of an otherwise successful upgrade, the upgrade is interrupted and the following is seen in the browser:

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 A system error has occurred. If this problem persists, please contact your JIRA administrators. Otherwise, please create a support issue on our support system at http://support.atlassian.com with the following information: a description of your problem cut & paste the error and system information found below Cause: java.lang.NullPointerException Stack Trace: [hide] java.lang.NullPointerException at com.atlassian.crowd.embedded.core.CrowdDirectoryServiceImpl.storeLdapConnectionPoolConfiguration(CrowdDirectoryServiceImpl.java:308) at com.atlassian.crowd.embedded.core.CrowdDirectoryServiceImpl.initialiseConnectionPoolSystemProperties(CrowdDirectoryServiceImpl.java:291) at com.atlassian.crowd.embedded.core.CrowdDirectoryServiceImpl.getApplication(CrowdDirectoryServiceImpl.java:263) at com.atlassian.crowd.embedded.core.CrowdDirectoryServiceImpl.findAllDirectories(CrowdDirectoryServiceImpl.java:81) at com.atlassian.jira.user.util.DefaultUserManager.getWritableDirectories(DefaultUserManager.java:261) at com.atlassian.jira.user.util.DefaultUserManager.hasPasswordWritableDirectory(DefaultUserManager.java:277)

Diagnosis

This is seen when the restore includes the osuser.xml file, but the External User Management flag is not set to True.

Cause

This is caused by the absence of an Internal directory configuration in the osuser.xml file.

Solution

Resolution

  1. Remove the osuser.xml file.

  2. Restart JIRA.

Updated on April 8, 2025

Still need help?

The Atlassian Community is here for you.