Cannot log into JIRA after successful upgrade from 4.4.5 to 5.1.8 - NoSuchMethodError

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

After completing an in-place upgrade, JIRA users are unable to login.

The following appears in the catalina.out file:

1 java.lang.NoSuchMethodError: com.atlassian.jira.bc.security.login.LoginProperties$Builder.contactAdminLink(Ljava/lang/String;)Lcom/atlassian/jira/bc/security/login/LoginProperties$Builder;

Cause

This is typically caused by leftover cruft from the previous JIRA installation

Resolution

  • Remove JIRA entirely

  • Back up <jira-home>

  • Download a new copy of JIRA

  • Install new JIRA according to instructions

  • Connect JIRA to the existing database using the config.sh or config.bat tool

  • Restore attachments

Updated on April 8, 2025

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