'Cannot get issue navigator restriction clause' Error Appears in Logs After Modifying jira-application.properties

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

After editing jira-application.properties, the folloiwng errors appears in the logs:

1 2 2008-04-10 10:32:38,910 TP-Processor1 WARN [web.action.issue.IssueNavigator] Cannot get issue navigator restriction clause for: XXX key=jira.search.views.default.max

Cause

If you have edited the jira-application.properties file, there may be a white space after one of the properties that was edited. The name of the property will be specified in the error message that appears as it does in the above message key=jira.search.views.default.max.

Resolution

  1. Open <atlassian-jira/WEB-INF/classes/jira-application.properties

  2. Remove the white space after the value set for the property in the error message.

  3. Restart JIRA

Updated on April 8, 2025

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