Cannot Edit Issue After User Has Been Deleted
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Symptoms
When trying to edit an issue you are presented with an error, and the following may appear in the logs:
1
2
/secure/EditIssue!default.jspa [500ErrorPage.jsp] Exception caught in 500 page Error occurred while retrieving user with username 'charlie'.
com.atlassian.jira.exception.DataAccessException: Error occurred while retrieving user with username 'charlie'.
Cause
The issue may be assigned to (or reported by) a user that has been deleted. JIRA normally does not allow you to remove a user until after they have had all issues unassigned from them and are no longer listed as the reported. However if you are using external user management such as Active Directory, it is possible to bypass this and delete a user that still has issues assigned to them.
Resolution
To resolve this, create a new user in JIRA with the same username / email address as the deleted user. Re-assign any issues that have been assigned to that user or that user has reported and then delete the re-created user account.
Was this helpful?