Cannot edit dashboards and filters owned by specific user after Jira upgrade

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

After upgrading from a previous Jira version eg (7.1.x) to Jira version 8.5.1, users can't edit Dashboards and Filter they used to edit before upgrade.

Environment

Jira Core and Software 7.2.2 and above

Diagnosis

No errors or warnings are logged in atlassian-jira.log.

Cause

The problem is caused by a difference in how Jira Dashboards and Filters are shared.

In version 7.1.x ( and prior) the option is "shared with everyone" and in the new version it is called "shared with logged in users".

During upgrades the previous option might not be properly migrated to the new one.

Solution

Once the new sharing option has been updated, dashboards and filters become properly editable and user was able to edit as it was before.

⚠️ If none of your users are able to reach the 'Share Dashboard' option, you can copy the URL from the 'Share Dashboard' option on a dashboard which does work and manually modify the pageId in the URL to access the broken dashboard's Sharing configuration page. To find the pageId, simply browse to the dashboard you're having trouble with and copy the value of the 'selectPageId=' parameter.

Example "Share Dashboard" URL: $BASE_URL/secure/EditPortalPage!default.jspa?pageId=10100&returnUrl=/secure/Dashboard.jspa

Updated on April 8, 2025

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