Jira prevents issue type deletion due to active issues, but the associated issues cannot be found

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

When attempting to delete an issue type, Jira will inform you about how many issues are still utilizing that particular issue type:

Note: This issue type cannot be deleted - there are currently 2 active issues and 0 archived issues with no suitable alternative issue types. (...)

Migrate the issues below to a new issue type in order to delete:

• XX active issues

Environment

Jira/Jira Service Management Cloud

Diagnosis

On the screen that informs you that you need to replace the issue type of active issues before you can delete the Issue Type, you attempt to migrate issues, or click to view the active issues of that type ("XX active issues"), but at least some of the issues can't be found.

Cause

Jira Cloud doesn't allow the deletion of a particular issue type if there are issues still utilizing it. If you can't find some of the issues reported by the Delete Issue Type page, those may belong to an archived project.

Issues are stored in the database on a cloud platform, so contact Atlassian Support to get the list of projects to which those issues belong.

Solution

Even issues of archived projects will prevent the proper removal of an issue type. So, you will need to restore the archived project and then re-assign those to a new issue type. Only then will you be able to delete the Issue Type. The steps to restore an archived project are listed here: Restore a project.

  1. Begin by restoring the archive project for a given Issue Type. If there are many issues to be restored, you may also use the Restore deleted or archived project REST API endpoint to facilitate the operation. 

  2. Try deleting the (now unarchived) issues again.

  3. You should now be able to proceed by clicking on "Migrate issues."

After all issues have been moved to a new type, you can proceed to delete the issue type.

This behavior is documented in the following open feature request:

Please consider this KB article as a workaround until the feature request is implemented.

Updated on March 3, 2025

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